Degraded performance in our Services

Incident Report for e-satisfaction.com

Resolved

This incident has been resolved.
Posted Mar 21, 2025 - 19:44 EET

Monitoring

We can see that performance is back to normal.

We are monitoring our system and preparing our incident report.
Posted Mar 21, 2025 - 12:49 EET

Investigating

We are currently experiencing a degraded performance in our API affecting our Dashboard and our Collection mechanism.

We are in the process of identifying the root cause!

We will keep you updated!
Posted Mar 21, 2025 - 12:33 EET
This incident affected: API, Dashboard, and Collection.