Data Warehouse Delays affecting Portal Reports

Incident Report for e-satisfaction.com

Resolved

All data have been synced completely!
Posted Jun 03, 2026 - 07:51 EEST

Identified

We experience delays in our data warehouse which affects the data transfer speed from our surveys to our Data Warehouse, so that they are available to our Portal Reports.

We have identified the issue and we are running backfills to fix the data gap!
Posted Jun 02, 2026 - 14:20 EEST
This incident affected: Reporting Dashboard (portal.e-satisfaction.com).