Reports appear broken on Reports Portal

Incident Report for e-satisfaction.com

Resolved

The incident has been resolved and all reports are back to normal!
Posted Feb 27, 2026 - 16:42 EET

Identified

We have identified that some reports appear broken on our Reporting Portal.

We have already found the root-cause and we are working on a solution asap.

We will post an update once it's fixed!
Posted Feb 27, 2026 - 15:43 EET
This incident affected: Reporting Dashboard (portal.e-satisfaction.com).