Major disruptions in background services and some customer-facing services

Incident Report for e-satisfaction.com

Resolved

All background services are operating as expected.
Posted Jun 15, 2026 - 12:17 EEST

Monitoring

We have identified the issue and we are monitoring performance, to make sure that every service is up and running properly.
Posted Jun 15, 2026 - 10:40 EEST

Investigating

We are investigating multiple internal errors that have caused disruption of our services and prevent us from fulfilling data flows.

We will keep posting updates once we have more information.
Posted Jun 15, 2026 - 10:19 EEST
This incident affected: Background Services (Queue Items Dispatch, Pipeline Bridges, Alerts, Questionnaire Sequences, Webhooks, Async Data Import, Async Data Export) and Configuration Dashboard (app.e-satisfaction.com), Collection, API.